Contents

1. Welcome to COPA-DATA help ................................................................. 4
2. Licensing .................................................................................................. 4
3. License zenon ............................................................................................. 5
4. Demo mode ................................................................................................. 6
5. Version and license information .................................................................. 6
6. Selecting the appropriate license size ........................................................ 7
7. Types of licensing ....................................................................................... 10
   7.1 Soft licensing .......................................................................................... 11
   7.2 Dongle licensing ..................................................................................... 12
      7.2.1 CodeMeter ....................................................................................... 12
      7.2.2 WibuKey ......................................................................................... 41
8. Command line parameter for licensing tool .............................................. 44
9. Remote licensing ....................................................................................... 44
10. Characteristics of the Server Client operation .......................................... 45
11. Everywhere Server by zenon ................................................................. 46
1. Welcome to COPA-DATA help

ZENON VIDEO-TUTORIALS

You can find practical examples for project configuration with zenon in our YouTube channel (https://www.copadata.com/tutorial_menu). The tutorials are grouped according to topics and give an initial insight into working with different zenon modules. All tutorials are available in English.

GENERAL HELP

If you cannot find any information you require in this help chapter or can think of anything that you would like added, please send an email to documentation@copadata.com (mailto:documentation@copadata.com).

PROJECT SUPPORT

You can receive support for any real project you may have from our Support Team, who you can contact via email at support@copadata.com (mailto:support@copadata.com).

LICENSES AND MODULES

If you find that you need other modules or licenses, our staff will be happy to help you. Email sales@copadata.com (mailto:sales@copadata.com).

2. Licensing

To be able to use zenon as an editor or Runtime, the product must be licensed. zenon runs in Demo Mode (on page 6) until it has been licensed.
3. License zenon

There are several possibilities for licensing zenon:

1. To license
   - In Windows, open Start -> All programs -> COPA-DATA -> Licensing, or
   - In the zenon Editor, open File -> General configuration -> License product ... or:
   - In the zenon Editor, open Help -> About -> Change/request license, or
   - In the Startup Tool, click on the Tools button, select Licensing then click on Start.

2. The dialog for entering license data opens.

3. Select zenon Editor/Runtime

4. Enter serial number and activation number
   You find the data for this:
   - on your license certificate
   - On the license sticker
   Note: Pay attention to capital letters and small letters when entering the data!

5. After the Editor/Runtime is restarted, use zenon with the license entered

Licensing Dialog

![Licensing Dialog Image]
### Parameter Description

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editor/Runtime</td>
<td><strong>Active</strong>: License is valid for the zenon Editor or the zenon Runtime.</td>
</tr>
<tr>
<td>Web Server</td>
<td><strong>Active</strong>: License valid for zenon Web Server.</td>
</tr>
<tr>
<td>Serial number</td>
<td>License serial number. If there is already a license available, its serial</td>
</tr>
<tr>
<td></td>
<td>number is displayed here. Enter the current serial number here.</td>
</tr>
<tr>
<td>Activation number</td>
<td>License activation number. If there is already a license available, its</td>
</tr>
<tr>
<td></td>
<td>activation number is displayed here.</td>
</tr>
<tr>
<td><strong>OK</strong></td>
<td>Import data and start zenon with this license when it is next started.</td>
</tr>
<tr>
<td><strong>Cancel</strong></td>
<td>Discard entries and use zenon with the previous license or no license.</td>
</tr>
<tr>
<td><strong>Request soft license</strong></td>
<td>Opens the dialog to request a soft license.</td>
</tr>
</tbody>
</table>

### 4. Demo mode

If the editor is not licensed, it runs in demo mode. Runtime runs in demo mode if it is not licensed.

<table>
<thead>
<tr>
<th>Demo mode</th>
<th>Conditions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Editor</strong>:</td>
<td>The Editor runs:</td>
</tr>
<tr>
<td></td>
<td>- the first 40 times it is started for 30 minutes</td>
</tr>
<tr>
<td></td>
<td>- from the 41st to the 50th Start: 20 minutes</td>
</tr>
<tr>
<td></td>
<td>- from the 51st Start at: 10 minutes</td>
</tr>
<tr>
<td><strong>Runtime</strong>:</td>
<td>A not-licensed Runtime runs for 30 days or 40 starts according to which</td>
</tr>
<tr>
<td></td>
<td>comes first. From the 41st start or the 31st day on, Runtime only runs</td>
</tr>
<tr>
<td></td>
<td>for 10 minutes.</td>
</tr>
</tbody>
</table>

The user is informed that it is running in demo mode when it starts.

**Note**: This behavior for unlicensed version is also applicable to the zenon Logic Workbench and Runtime.

### 5. Version and license information

You can see the version and license that you are currently using and which modules are included in this:
Selecting the appropriate license size

- In the Editor: If, in the zenon Editor, you click on Help -> About....
- In Runtime: If you execute the Show license information function.

**Note:** The Change/request license button is not present in Runtime.

<table>
<thead>
<tr>
<th>Parameters/buttons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Version</td>
<td>Version number of Editor or Runtime.</td>
</tr>
<tr>
<td>Serial Number</td>
<td>License serial number.</td>
</tr>
<tr>
<td>Activation number</td>
<td>License activation number.</td>
</tr>
<tr>
<td>Expiration time (optional)</td>
<td>Information on the expiration date of the license for limited licenses.</td>
</tr>
<tr>
<td>Licensed modules</td>
<td>Information on licensed module.</td>
</tr>
<tr>
<td>Change/request license</td>
<td>Opens the dialog for licensing (on page 5).</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the dialog.</td>
</tr>
</tbody>
</table>

6. **Selecting the appropriate license size**

The licenses for the Editor and the Runtime are calculated by adding up the necessary TAGs or IOs.
CALCULATION VIA TAGS

1 TAG equals 1 variable. For determining the license size, consider the total number of TAGs (= variables) of the following drivers:

» PLC drivers and bus drivers

Variables of the following drivers do not count:

» Internal driver
» system driver
» mathematics driver
» simulation driver

You can license TAGs for the Editor and the Runtime in the following gradation:

» 64 TAGs
» 128 TAGs
» 256 TAGs
» 512 TAGs
» 1,024 TAGs
» 2,048 TAGs
» 4,096 TAGs
» 8,192 TAGs
» 16,384 TAGs
» 65,536 TAGs
» unlimited

A license upgrade to a higher number of TAGs is possible at any time.

CALCULATION VIA I/Os

License can also be based on I/Os. For determining the license size, consider the total number of I/Os of the following drivers:

» PLC drivers and bus drivers

Variables of the following drivers do not count:

» Internal driver
» system driver
» mathematics driver
» simulation driver
Selecting the appropriate license size

**CALCULATION**

<table>
<thead>
<tr>
<th>Data type</th>
<th>Valence</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 bit</td>
<td>1 I/Os</td>
</tr>
<tr>
<td>1 byte</td>
<td>8 I/Os</td>
</tr>
<tr>
<td>1 WORD</td>
<td>16 I/Os</td>
</tr>
<tr>
<td>1 DWORD</td>
<td>16 I/Os</td>
</tr>
<tr>
<td>1 float</td>
<td>16 I/Os</td>
</tr>
<tr>
<td>1 string (max. 64 characters)</td>
<td>16 I/Os</td>
</tr>
</tbody>
</table>

If you cannot find the desired data type in the list, it is because of the selected driver. Some drivers have a specific denotation of the data types. You will find more information in the driver documentation of the driver you use. You will find this either in the online help in the **Drivers** section, as a PDF file on our installation medium or on our website [www.copadata.com](http://www.copadata.com) in the download section.

**Example**

96 binary and 20 numerical values are to be visualized in zenon:

*Multiply the 20 numeric values with 16 and you receive 320 I/Os. Add these to the 96 binary values. As a result you get 416 I/Os, which now are the basis for the license size.*

**DISPLAY IN ZENON**

In the status line of the detail view of the variables the following information can be found:

- How many I/Os are used currently.
- How many I/Os are licensed.

An example:

- 3799/550/1: 3799 entries exist, 550 are listed because of a filter, one entry is selected.
- For project 22730 an unlimited number of I/Os is licensed.
NOTE FOR CLIENT LICENSE

You can use client licenses if:

- The start project is a standalone project or a client
- The start project uses a maximum of 64 TAGs when a license is required, if it is not a client
- All subprojects are clients

7. Types of licensing

You can license Zenon in different ways:

- Soft licensing (on page 11): Requests a unique PC identification number when the editor or Runtime is started.
  Characteristics:
  - The license cannot be stolen.
  - The license is computer related.
  - Practical for notebooks.

- Dongle licensing (on page 12): Looks for a hardware dongle at a parallel port or USB port when the editor or Runtime is started.
  Dongles are available as:
  - Workplace dongle:
  - Network dongle: A certain number of licenses are booked on a central dongle on the network, which can be used at the same time as concurrent-use licenses.

Notes for dongles:

- easy handling
- A license can be taken from one PC to another by simply moving the dongle.
- No problems due to hard disk failures

Information

If there is no license or all licenses are assigned in the network, then the editor or Runtime starts in demo mode (on page 6).
7.1 Soft licensing

The soft license assigns a computer with a unique identification. In doing so, certain components of the computer are examined. This license always only works on a certain computer. If it is to be transferred to another computer or too many components on the licensed computer are changed, it must be reissued.

To obtain a software license:
1. In the File menu, select: General configuration -> License product.
2. The licensing dialog (on page 4) opens.
3. Enter the serial number.
4. Click on Request soft license.
5. The product licensing dialog opens. If this has not yet happened, enter the serial number.
6. Click on License request for soft licensing.
7. Enter your contact details.
8. Click on Next.
9. There are two possibilities for sending these:
   a) automatic
      • Click on the Send to button
      • Select the desired COPA-DATA organization
      • When clicking on OK, the license request is sent by your email program
      • via button Print you can print your copy or send it to a connected fax machine
   a) manually
      • Click on the Finish button
      • The license request is saved as a text file
      • An information window informs you of the name and save location
      • the file is automatically opened in the Text Editor
      • send the email by email or fax to your sales partner

As soon as you have received your license data, reopen the licensing dialog and enter your activation number.
7.2 Dongle licensing

With dongle licensing, a dongle is connected directly to the computer for an individual workspace license or to a network computer for a network license. Zenon uses two dongle systems:

- **CodeMeter** (on page 12) (included with setup)
- **WibuKey** (on page 41) (software included on installation medium)

Software necessary for the installation of CodeMeter licensing is also automatically installed during the installation of Zenon.

**CONFIGURATION**

In general, no further settings need to be made for dongles used locally. The use of network dongles may mean that individual configuration is necessary. You can find these in the respective dongle software.

For details of this, see the chapters on the **WibuKey** (on page 41) and **CodeMeter** (on page 12).

**WIBUKEY**

The additional WibuKey administration software is no longer automatically installed with the setup from Zenon version 7.50. This software is however supplied with Zenon. If necessary, install the current version of the WibuKey software from your Zenon installation medium:

```
...\AdditionalSoftware\WIBU-SYSTEMS WibuKey
```

**Note:** Users who already work with WibuKey continue to receive new licenses for their WibuKey dongles.

7.2.1 CodeMeter

The CodeMeter dongle can be used at a single workplace or in a network.

The following must be the case in order for CodeMeter to be used:

- The CodeMeter USB stick must be available in a USB port on the local computer or as a server on a network computer.
- The dongle firmware must be at least version 1.16 or above

**Note:** Descriptions of the CodeMeter WebAdmin relate to version 6.10 thereof.
ATTENTION

If the dongle is removed during ongoing operation, zenon closes and is opened in demo mode until a valid license is detected again.

CONFIGURATION

To configure, start the CodeMeter control center application via: Windows Desktop -> Start -> All programs -> CodeMeter -> CodeMeter Control Center.

The CodeMeter control centre opens with 2 tabs:

- **License**: Contains information on the dongles found.
- **Events**: Displays the number of sticks connected, the license entries, the firm items found and all access to the CodeMeter Runtime server. To log the entries on a permanent basis, activate the Logging entry in the File menu.

**Note:** In versions before 6.10, there is also the Allocation tab available to configure allocation processes for licenses. From CodeMeter version 6.10, it is only still available if the corresponding entries are present on the client.

Information

This manual covers the most important applications for zenon users. You can find detailed help on the use of CodeMeter in the help integrated into CodeMeter. To call these up in the:

- Control center: In the Help menu, click on the Help entry.
- WebAdmin: Click on the question mark in the second line of the menu.

The CodeMeter help is called up context-sensitively.
License tab

Dongles and licenses are displayed and configured in this tab.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>License</td>
<td>Lists all active CodeMeter sticks.</td>
</tr>
<tr>
<td>Name:</td>
<td>Individual name of the stick selected; can be amended using the button with the pen (to the right of it).</td>
</tr>
<tr>
<td>Serial Number:</td>
<td>Serial number of the stick selected.</td>
</tr>
<tr>
<td>Version:</td>
<td>Firmware version of the selected stick.</td>
</tr>
<tr>
<td>Capacity:</td>
<td>Display of free memory in percentage and bytes.</td>
</tr>
<tr>
<td>Status</td>
<td>Selection of the status of the selected CodeMeter stick using radio buttons.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Deactivated</strong>: The stick connected is deactivated and cannot be used by any application.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Activates when connected</strong>: The stick is activated as long as it is connected. It is automatically deactivated after removal from the PC.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Activated</strong>: The stick is fully activated and remains activated after it is removed. Recommended status: Ensures that unauthorized persons do not have access to licenses and personal data (e.g. CmPasswordManager)</td>
</tr>
<tr>
<td></td>
<td>Changes must be confirmed using the dongle password.</td>
</tr>
<tr>
<td>License updating</td>
<td>Starts the assistant to add, amend and delete licenses.</td>
</tr>
<tr>
<td>Eject</td>
<td>Allows the stick to be ejected.</td>
</tr>
<tr>
<td>Change password</td>
<td>Enables the password to be changed.</td>
</tr>
<tr>
<td>CodeMeter has been started/stopped</td>
<td>Information on whether the CodeMeter service is running. Can be changed in the Action menu.</td>
</tr>
<tr>
<td>WebAdmin</td>
<td>Starts the web browser with the administration user interface for network dongles Port 22350 must be open for this. For more details, see the Network administration (on page 21) chapter.</td>
</tr>
</tbody>
</table>

**Update certified time**

You can update the certified time saved in the dongle via the CodeMeter time server. You need access to the Internet for this.

To update the time:

1. Start the CodeMeter WebAdmin
2. Check your network settings (on page 22):
   a) Are the proxy settings correct in CodeMeter Webadmin?
   b) Is your access data up-to-date?
3. Navigate to the **Container** menu.
4. Select the desired stick.
5. Click on **CMContainer info**

![Image of CodeMeter WebAdmin showing container settings](image)

6. Navigate to the **Certified time (CM Container)** entry.
7. Click on the symbol to update:
8. You are notified that this will update all sticks.
9. Click on **OK**.
10. You receive information on the update carried out.
    Hint: In the event of an error message (on page 34), you primarily check your access data.
Request license

To request or update licenses for CodeMeter, select the Update license button in the Licenses tab in the CodeMeter control center (on page 12). The license update assistant starts:

Decide if you are:
- requesting a license
- entering a license update
- want to create a receipt for COPA-DATA

LICENSE REQUEST

With license requests, you can:
Types of licensing

- extend an existing COPA-DATA license
- create a new COPA-DATA license

**ENHANCE LICENSE**

To add another COPA-DATA license:

1. In the **Option** step, select **Enhance existing license**.
2. Click on **Next**.
3. Select in COPA-DATA.
4. Click on **Next**.
5. Select the save location.
6. Click on **Apply**.
7. Send the file to your COPA-DATA sales partner.

**REQUEST NEW LICENSE**

To request a new COPA-DATA license:

1. In the **Option** step, select **Enhance existing license**.
2. Click on **Next**.
3. Enter the **Firmcode** that you received from COPA-DATA.
4. Click on **Next**.
5. Select the save location.
6. Click on **Apply**.
7. Send the file to your COPA-DATA sales partner.

Adapt license

You can adapt the scope of your license concerning extent and runtime at any time. To do this:

1. Order the desired change at COPA-DATA.
2. You will receive a *.WibuCmRaU file for your dongle.
3. Install the file
   a) either via double click on the file
   b) or by dragging the file ion the CodeMeter control center

You will receive a message about successfully updating your license.

If you receive an error message (on page 34 229), the license on the dongle is already up to date.

If it is necessary for your license request to create a .WibuCmRaC file or to install the .WibuCmRaU file with the update manually, follow the instructions in chapter Update license manually (on page 19).

Request or update license

To update your license manually:

1. Create a .WibuCmRaC file
2. Send this file to COPA-DATA.
3. You will get an updated .WibuCmRaU file back.
4. Copy this to the dongle

CREATE WIBUCMRAC FILE

1. Make sure that the CodeMeter dongle is connected to your PC.
2. Open the CodeMeter Control Center.
   Path: Start -> Programs -> CodeMeter -> CodeMeter Control Center
3. In the License tab, click on the License update button.
4. The license update assistant starts.
5. Click on **Next**.

![CmFAS Assistant](image1)

*Welcome to the CmFAS Assistant!*

The CodeMeter Field Activation Service (CmFAS) assistant helps you adding, changing and deleting licences from the license management system CodeMeter.

With the CmFAS assistant you can create license request files, which you can send to the vendor of the software by email. You can also import the received license update files with the CmFAS assistant into the license management and create a receipt of the import for the vendor.

6. Select **Create license** and click **Next**.

![CmFAS Assistant](image2)

*Please select the desired action*

- **Create license request**
  - Choose this option if you want to create a license request file in order to send it to the vendor of the software.

- **Import license update**
  - Choose this option, if you received a license update file from the software vendor and want to import this file.

- **Create receipt**
  - Choose this option if you want to confirm the successful import of a license update file for the software vendor.

7. Select **Enhance existing license**.
8. Click on **Next**.

9. Select the manufacturer and click on **Next**.

10. Select the desired location for the appropriated `.WibuCmRaC` file.

11. Click on **Apply**.

12. The `.WibuCmRaC` file is created.

13. Send the file to sales@copadata.com or the address you have been given.

**INSTALL WIBUCMRAU FILE**

You will receive, from COPA-DATA, an updated *.*.WibuCmRaU file.

Install the file via double click on the file on the dongle.

Alternative:

1. Open the CodeMeter control center.
2. In the dialog for updating licenses, select **Lizenzaktualisierung einspielen**.
3. Follow the instructions given to you by the installation wizard.

**Network administration using WebAdmin**

For network administration, start the WebAdmin user interface by clicking on the **WebAdmin** button in the CodeMeter control center. Detailed information on the individual settings can be found in the CodeMeter WebAdmin help pages. You can get to this using the question mark (?) symbol in WebAdmin. The most important options and instructions are also in this document:

- CodeMeter stick administration (on page 27)
- License administration (on page 28)
Types of licensing

- Saving license data (on page 28)
- Network settings (on page 22)
- Proxy settings (on page 22)

⚠️ **Attention**

*CodeMeter WebAdmin* uses port 22350 by default.

**Note:**
- If a firewall other than that integrated into the Windows operating system is used, this port must be enabled.
- If the port is changed, the WebAdmin surface cannot be started, because the port is part of the address.
  
  For example: http://localhost:22350/configuration/extra.html

  In this case, use appropriate freeware tools or standard Windows tools to determine which port is currently being used and enter this address into the address line of the browsers instead of 22350.

  Then amend the port in WebAdmin via *Settings -> Advanced -> Extras*.

**Network**

For faultless communication with a Network dongle and the start of the *WebAdmin*, correct network settings are a requirement.
## Types of licensing

### SERVER SEARCH LIST

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Server search list</strong></td>
<td>Display of the available CodeMeter servers. The entries can be removed and sorted. The order defined here decides the order of connection attempts made by clients. Only the servers defined in the list are searched for. This way, requests from clients are directed to a defined CodeMeter Network server. <strong>Note</strong>: If a CodeMeter Server is in a different subnetwork, use the IP address for the search list. This search list should only be used if the CM Stick cannot be found in the network.</td>
</tr>
<tr>
<td><strong>Add new server</strong></td>
<td>Opens the dialog for selecting a server. You define the CodeMeter network server here using its computer name or IP address.</td>
</tr>
<tr>
<td><strong>Apply</strong></td>
<td>Applies the changes.</td>
</tr>
<tr>
<td><strong>Restore default</strong></td>
<td>Restores the default settings.</td>
</tr>
</tbody>
</table>
PROXY

For access to CodeMeter services in the Internet, such as time server, enter the applicable access data for your company here.

⚠️ Attention

CodeMeter notes this credentials. If you regularly change your access password, you must also change this in the CodeMeter WebAdmin proxy settings!

ACTIVATE AS SERVER

To activate a stick as a server in the network:
1. Click on **Settings -> Server -> Server access.**

![CodeMeter WebAdmin interface](image)

- **Network Server**
  - Enable
  - Network Port: 22222

- **CmWAN Server**
  - Disable
  - Enable

Applies only after restarting CodeMeter.

2. In the **Network server** area, click on **Activate.**

If you need another port for communication, then change it using **Settings -> Advanced -> Extras.**

The computer becomes a **CodeMeter** network server and makes all its licenses available in the network.
AMEND PORT

You can amend several communication parameters via Settings -> Advanced -> Extras. **CodeMeter WebAdmin** communicates using port 22350 by default. You can amend it here if necessary.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network port</td>
<td>Port for <strong>CodeMeter</strong> communication in the network.</td>
</tr>
<tr>
<td></td>
<td>Default: 22350</td>
</tr>
<tr>
<td></td>
<td>The value can be adjusted individually. In this case, it must be ensured that all <strong>CodeMeter</strong> Runtime servers use the same port. The <strong>CodeMeter</strong> service must be restarted once a change has been made.</td>
</tr>
<tr>
<td></td>
<td><strong>Recommendation</strong>: do not change port.</td>
</tr>
<tr>
<td>Network waiting time</td>
<td>Time that is waited for a response from the server.</td>
</tr>
<tr>
<td></td>
<td>Default: 100 seconds</td>
</tr>
<tr>
<td>UDP response time</td>
<td>Maximum response time within which a UDP request must be answered.</td>
</tr>
<tr>
<td></td>
<td>Default: 1000 milliseconds.</td>
</tr>
</tbody>
</table>
CodeMeter sticks

The WebAdmin starts in the **Container/All containers** view.

Here, you select the desired dongle and the desired information and actions:

- **Licenses**: Display of the available licenses.
- **CmContainer Infos**: Information on the dongle.
- **User data**: Data on users, number of licenses and validity.
- **Backing up and restoring**: Backing up the data from a stick to a file and restoring it.

CMCONTAINER INFOS

You show details of the selected dongle with the **CmContainer Infos** button.
### Types of licensing

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CmStick</strong></td>
<td>Display of the detected sticks and their status. All other information relates to the selected stick.</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>Shows the name given in the control center (on page 12).</td>
</tr>
<tr>
<td><strong>Serial Number</strong></td>
<td>Serial number of the stick.</td>
</tr>
<tr>
<td><strong>CmContainer type</strong></td>
<td>Hardware version of the stick.</td>
</tr>
<tr>
<td><strong>Drive</strong></td>
<td>Drive information for the stick, drive sizes are only given for sticks with flash memory.</td>
</tr>
<tr>
<td><strong>Status</strong></td>
<td>Activation status as defined in the control center (on page 12).</td>
</tr>
<tr>
<td><strong>System time (PC)</strong></td>
<td>Local time on the CodeMeter Runtime server.</td>
</tr>
<tr>
<td><strong>System time (CMContainer)</strong></td>
<td>Internal time saved on the stick.</td>
</tr>
<tr>
<td><strong>Certified time</strong></td>
<td>The certified time saved on the stick. Is amended with the update symbol (to the right).</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: to update (on page 15) using the CodeMeter timeserver, you require an active internet connection. Ensure that the network settings (on page 22) are correct, in particular in relation to current access data.</td>
</tr>
<tr>
<td><strong>Free memory</strong></td>
<td>Free memory available on the stick. To defragment the memory, click on the Defragment symbol (to the right).</td>
</tr>
</tbody>
</table>

### Administering licenses

You administer your licenses in the **Licenses** tab in the **Container** menu.

1. Select the desired dongle.
2. You can find information on the licenses of these dongles below the `<COPA-DATA>` subheading.
3. For further details, click on the figure in the **Product Code** column.
OVERVIEW
Types of licensing

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Product Code</strong></td>
<td>Numerical value for the product. Clicking on the number leads to the details.</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>Dongle name</td>
</tr>
<tr>
<td><strong>Usage units</strong></td>
<td>If applicable, display of usage units remaining.</td>
</tr>
<tr>
<td><strong>Expiration date</strong></td>
<td>If applicable, the expiration date is shown. Afterwards, zenon switches to demo mode (on page 6).</td>
</tr>
<tr>
<td><strong>Number of licenses</strong></td>
<td>Total number of licenses</td>
</tr>
<tr>
<td><strong>Feature Map</strong></td>
<td>Licenses that are supplied with different functionality or modules.</td>
</tr>
</tbody>
</table>

**DETAILS**

![CodeMeter WebAdmin](image)

**TIME LIMITS**

A dongle can also have a time limit through:

- Expiration date
- Time period for use
EXPIRATION DATE

The dongle can be equipped with a fixed expiration date. The expiration date denotes the last day on which the license is valid. zenon switches to demo mode afterwards. The expiration date is shown in CodeMeter WebAdmin.

To find out the expiration date:

1. Navigate to the dongle.
2. The end date is shown in the Date of expiration column in the Licenses view.
3. The end date is also shown on the **Value** column in the detail view.

**TIME PERIOD FOR USE**

The dongle can be equipped with a specified usage period. This starts from the first time that zenon Editor or Runtime is used. Once the time period has expired, zenon switches to demo mode. To check the time limit:

1. Navigate to the dongle.
2. Show the licenses.
3. Click, in the entry under COPA-DATA, on the figure in the **Product Code** column.

   The **Product Item Details** window opens.
In the **Usage period** line, you can see the licensed time period and the start date in the **Value** column.
## Troubleshooting

<table>
<thead>
<tr>
<th>Error</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>zenon only runs in demo mode.</td>
<td>Check your licenses. Check the connection to the network dongle. Check if the license information (SERIAL7= and ACTIVATIONKEY7=) was correctly entered in zenon6.ini. Take care for possible blanks behind the serial number (SERIAL7=) or the activation key (ACTIVATIONKEY7=). Directory for zenon6.ini: Vista: %ProgramData%\COPA-DATA\System</td>
</tr>
<tr>
<td>Dongle is not found.</td>
<td>Check the network settings (on page 22). If the stick is in another domain, add it to the server list (on page 22). Increase the UDP response time (on page 22). If it is a virtual machine, then configure the stick as removable media (on page 35). <strong>Attention</strong>: Configuration as removable media can - depending on the computer configuration - also lead to a computer no longer booting. Configure the stick as HID (on page 36).</td>
</tr>
<tr>
<td>Error 410 (with SD cards)</td>
<td>The connection to the SD card is unstable. Use an external card reader.</td>
</tr>
<tr>
<td>Certified time cannot be updated.</td>
<td>Please check: Proxy settings (on page 22), especially access data and Password List of time server under Settings -&gt; time server for example: cmt ime.codemeter.com, cmt ime.codemeter.de, cmt ime.codemeter.fr, cmt ime.codemeter.us</td>
</tr>
<tr>
<td>Error message at updating the license: Error at updating the CmSticks x-xxxxxxx: This update can no longer be read in. The content of the CmStick has a newer version, error229.</td>
<td>The update for this license has already been written to the dongle. The dongle is up-to-date.</td>
</tr>
</tbody>
</table>
Windows operating system shows the message:

**Low Memory**

The dongle is identified as local memory. In some cases, this can lead to the operating system giving the message "Insufficient memory".

This message can be ignored.

Alternatively, the dongle can also be configured as removable media. For details on configuration, see the Configure dongle as removable media or HID (on page 35) section.

**Attention**: Configuration as removable media can - depending on the computer configuration - also lead to a computer no longer booting.

Windows operating system no longer shows symbol for the Recycle Bin.

This may happen if the dongle is identified as a fixed local network.

Alternatively, the dongle can also be configured as removable media. For details on configuration, see the Configure dongle as removable media or HID (on page 35) section.

**Attention**: Configuration as removable media can - depending on the computer configuration - also lead to a computer no longer booting.

---

**Configuration possibilities for the CodeMeter dongle**

The dongle is integrated into the system as an HID (Human Interface Device) device by default. This configuration is recommended. The dongle can also be configured as a local mass-storage device or removable media.
CONFIGURATIONS

<table>
<thead>
<tr>
<th>Configured as:</th>
<th>Description</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>HID</td>
<td>The dongle:</td>
<td>Only available for <strong>CodeMeter</strong> dongles without memory.</td>
</tr>
<tr>
<td></td>
<td>▶ Is not displayed in the list of available drives</td>
<td></td>
</tr>
<tr>
<td></td>
<td>▶ Is not allocated a drive letter.</td>
<td></td>
</tr>
<tr>
<td><strong>Local mass-storage device</strong></td>
<td>The dongle is displayed and managed as a local drive. For configuration, see the Configure dongle as an HID or mass-storage device (on page 36) section.</td>
<td>Can lead to:</td>
</tr>
<tr>
<td></td>
<td>▶ The operating system reporting too little memory for the dongle</td>
<td></td>
</tr>
<tr>
<td></td>
<td>▶ the icon for the Windows Recycle Bin no longer being displayed</td>
<td></td>
</tr>
<tr>
<td></td>
<td>▶ the dongle not being found in virtual machines</td>
<td></td>
</tr>
<tr>
<td>Removable media</td>
<td>The dongle is displayed and managed as removable media. For details about configuration see the <strong>Configure dongle as removable media</strong> chapter.</td>
<td><strong>With configuration as removable media:</strong></td>
</tr>
<tr>
<td></td>
<td>▶ The booting of the computer can be prevented for with computers that can boot from a USB drive</td>
<td></td>
</tr>
<tr>
<td></td>
<td>▶ The dongle appears as a drive in the task bar and can be removed (ejected) at any time</td>
<td></td>
</tr>
</tbody>
</table>

**Configure dongle as an HID or mass-storage device**

**CodeMeter** supports, from version 5.0, the **Human Interface Device (HID)** class of USB standards. CodeMeter dongles can therefore log onto the system as a HID instead of a Mass Storage Device. The dongle is thus not shown in the list of available drives and is not allocated a drive letter. HID support is available for all CodeMeter dongles without memory. Special USB host drivers do not need to be installed for configuration, because the functionality is provided by the operating system.

**Requirements:**

- **CodeMeter** container with the identification "2-xxxxxxx" or 3-xxxxxxx".
- **CodeMeter** firmware 2.02 or higher.
- **CodeMeter** Runtime 5.0 or higher. Should the version of **CodeMeter** that you have installed be older, you can download the current **CodeMeter** Runtime from Wibu Systems (www.wibu.com (http://www.wibu.com/support-downloads.html)).
HID TO MASS STORAGE DEVICE

To switch USB communication from Human Interface Device (HID) to Mass Storage Device:

1. Check, in CodeMeter WebAdmin, the status in the Container -> CmContainer Info tab.
2. No drive is assigned.


4. Enter the following commands in the command input line that appears:
   `cmu32 /s [box mask-serial number] --set-config-disk MsdCommunication`

   **Note:** For `[box mask - serial number]`, enter the serial number of the stick.

   Once the command has been successfully executed, the following is displayed:
   Communication mode changed successfully.
   Please replug your CmDongle to apply the changes.

5. Remove the dongle from the computer.

6. Reconnect the dongle to the computer.
7. In the **CodeMeter Control Center**, the switch to MSD is shown in the **Events** tab.

8. In **CodeMeter WebAdmin**, check the drive in the **Container -> CmContainer Info** tab. A drive is entered but there is no flash memory.
MASS STORAGE DEVICE TO HID

To switch the USB communication from Mass Storage Device to Human Interface Device (HID):

1. Check, in CodeMeter WebAdmin, the status in the Container -> CmContainer Info tab.
2. A drive is assigned but there is no flash memory.


   Enter the following commands in the command input line that appears:

   `cmu32 /s [box mask-serial number] --set-config-disk HidCommunication`

   **Note:** For `[box mask - serial number]`, enter the serial number of the stick.

   Once the command has been successfully executed, the following is displayed:
   Communication mode changed successfully.
   Please replug your CmDongle to apply the changes.

4. Remove the dongle from the computer.
5. Reconnect the dongle to the computer.
6. In the **CodeMeter Control Center**, the switch to HID is shown in the **Events** tab.

![Image of CodeMeter Control Center]

7. Check the drive in **CodeMeter WebAdmin**, in the **Content/CmContainer** tab. Nothing should be entered.

![Image of CodeMeter WebAdmin]

Types of licensing
### 7.2.2 WibuKey

WibuKey can be used at a single workplace or in a network. The dongle must be active in a USB port or parallel port on the local computer or as a server on a network computer.

To check the settings of the stick:

1. Install the WibuKey administration software from the installation medium.
   
   **Save location:** \AdditionalSoftware\WIBU-SYSTEMS WibuKey
   
   Use this software for licensing with the network dongle.

2. Open the **Control Panel**.

3. Open the **WibuKey** system control element.

4. Select the stick to be tested on the local computer or on the network.
   
   To list server Wibu boxes in the network, click on the **Read in** button.

5. Check if the number in the last column of the second row is identical with the starting number of the stick.

You can read more about the operation of the stick in the *network dongle* (on page 41) chapter.

#### Network dongle

To use a WibuKey in the network as a dongle, the server and client must be configured accordingly:

- Server configuration (on page 42)
- Client configuration (on page 43)
Attention

WibuKey uses port 22347. This port is fixed and cannot be changed. Note:

- If a firewall other than that integrated into the Windows operating system is used, this port must be enabled if you wish to use the WibuKey as a network dongle.

Configuring the server

The WibuKey server has to run on the dongle server. The WibuKey server can be configured either as an application (e.g. started via Autostart) or as a service.

On installing the WibuKey software the options

32 Bit WkNet/WkLAN network server

Install as NT service with Autostart

have to be activated, so that the WibuKey server is installed as a service (recommended).

In order to start the WibuKey server as an application, a link to the file WkSvW32.exe has to be created in the Windows Autostart.

The file can be found in the C:/Programme/WIBUKEY/Server/ folder after installation.
Configuring a client

Some network settings for the client have to be entered in the Control Panel. Under WibuKey subsystems, you can select the type of network access you use. The licensing of zenon uses the WkLan subsystem.

Under Server Name/IP address either the server name or its IP address or a mask for the IP address is entered. With Browse the list is filled with all found dongle servers.

The entries are processed in the sequence of the list and also can be combined.

If the first entry is a certain server, it is checked, if the dongle server service runs on that PC and if a dongle is plugged in (faster!). If no dongle is found here and the next entry is a filter mask, all PCs in the network going with that filter mask are are tried out.

On the Contents page, the server(s) where the dongles were found should then be listed:
8. Command line parameter for licensing tool

The licensing tool can be controlled with the following flags as parameters:

Passing over a parameter is done by putting a `/` or a `-` before the parameter:

for example: `/silent` or `-silent`

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>request</td>
<td>forces the program to omit the first dialog and go straight to the dialog for requesting the activation key (it does not matter if the flag <code>/silent</code> or <code>-silent</code> is also used)</td>
</tr>
<tr>
<td>sernum:&lt;num&gt;</td>
<td>forces the program to use the serial number which is passed with <code>&lt;num&gt;</code> for licensing instead of reading the number from the zenon6.ini file.</td>
</tr>
<tr>
<td>actkey:&lt;key&gt;</td>
<td>forces the program to use the activation key which is passed with <code>&lt;key&gt;</code> for licensing instead of reading the key from the zenon6.ini file.</td>
</tr>
<tr>
<td>silent</td>
<td>forces the program to not show a dialog. The file License.txt is still created.</td>
</tr>
<tr>
<td>mailto:&lt;addr&gt;</td>
<td>works only in connection with the flag silent and forces the program to send the license request to the specified address <code>&lt;addr&gt;</code> via e-mail.</td>
</tr>
</tbody>
</table>

9. Remote licensing

To allocate a license to a computer via remote connection:

1. in the context menu of the project select Remote Transport -> Change password and display licensing
2. start the Remote Transport
3. as soon as the connection is established, the licensing of the remote computer is displayed
4. enter the serial number and the activation number of your license form
5. confirm the input by clicking OK
10. Characteristics of the Server Client operation

Licensing of modules in the server client operation has the following characteristics:

**HISTORIAN**

The following cases are distinguished:

- Server and client licensed: Archives can be opened and edited at the client
- Server licensed and client not licensed: Archives can be opened but not edited at the client
- Client not licensed and started as standalone: Archive window can be opened; the individual archives cannot be opened

**AUTOMATIC LINE COLORING**

The following cases are distinguished:

- Server licensed and client not licensed: ALC functionality is available unrestrictedly
- Client not licensed and started as standalone: ALC functionality is not available

**Information**

*If the Server is licensed for the Energy Edition, ALC is also licensed.*

**BATCH CONTROL**

The client gets the license from the server and does not need its own license. If the server does not have a license of its own, the client cannot use the module.

**LOAD MANAGEMENT**

The following cases are distinguished:

- Server licensed and client not licensed: **Load Management**EMS functionality is available without restriction
- Client not licensed and started as standalone: **Load Management**EMS functionality is not available
MESSAGE CONTROL

The client gets the license from the server and does not need its own license. If the server does not have a license of its own, the client cannot use the module.

11. Everywhere Server by zenon

*Everywhere Server* gets the license of the Runtime. The license for Everywhere Server is issued by Runtime. The *Everywhere Server* can not be used, if the Runtime does not have a corresponding license.

For this reason, it may happen that the Runtime is running, but the *Everywhere Server* can not be started because of missing license rights. In this case, please use the licensing tool (on page 4) in order to receive a corresponding license.