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Welcome to COPA-DATA help

1. Welcome to COPA-DATA help
GENERAL HELP
If you cannot find any information you require in this help chapter or can think of anything that you
would like added, please send an email to documentation@copadata.com
(mailto:documentation@copadata.com).

PROJECT SUPPORT
You can receive support for any real project you may have from our Support Team, who you can contact
via email at support@copadata.com (mailto:support@copadata.com).

LICENSES AND MODULES
If you find that you need other modules or licenses, our staff will be happy to help you. Email
sales@copadata.com (mailto:sales@copadata.com).

2. Licensing
To be able to use zenon as an editor and/or Runtime, the product must be licensed. zenon runs in Demo
Mode (on page 6) until it has been licensed.
To license zenon:
1.

open Start -> All programs -> COPA-DATA -> Licensing

or:
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in the zenon Editor open File -> General configuration -> License product ...
or:
Click, in the Startup Tool on the Tools -> Licensing -> Start button.
2.

the dialog for entering license data opens

3.

select zenon Editor/Runtime

4.

enter serial number and activation number

You find the data for this:


on your license certificate



On the license sticker



in the license file License.txt

Path Vista/7/8: C:\Users\Public\Documents\zenon_Projects\
Pay attention to capital letters and small letters when entering the data!
5.

after the Editor/Runtime is restarted, use zenon with the license entered
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Parameters

Description

Editor/Runtime

Active: License is valid for the zenon Editor and/or the zenon
Runtime.

Web Server

Active: License valid for zenon Web Server.

Serial Number

License serial number.
If there is already a license available, its license number is displayed
here.

Activation number:

License activation number.
If there is already a license available, its activasion number is
displayed here.

OK

Import data and start zenon

Cancel

Discard entries and use zenon with the previous license or no license.

Request soft license

Opens the dialog to request a soft license.

with this license when it is next started.

3. Demo mode
If the editor is not licensed, it runs in demo mode. Runtime runs in demo mode if it is not licensed.
Demo mode

Conditions

Editor:

The Editor runs:
 the first 40 times it is started for 30 minutes
 from the 41st to the 50th Start: 20 minutes
 from the 51st Start at: 10 minutes

Runtime:

A not-licensed Runtime runs for 30 days or 40 starts according to which comes first.
From the 41st start or the 31st day on, Runtime only runs for 10 minutes.

The user is informed that it is running in demo mode when it starts.
This behavior for unlicensed version is also applicable to the straton Workbench and Runtime.
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4. Version information
You can see which license you are currently using and which modules are included in this when starting
zenon in the start screen or after clicking on Info on... in theHelp menu:

Parameters

Description

Editor version

Editor version number.

Serial Number

License serial number.

Activation number:

License activation number.

Expiration time (optional)

Information on the expiration date of the license for limited
licenses.

Field with modules:

Information on licensed module.

In menu Help the entry Info about
version and the licensing.

opens a dialog box which offers information about the zenon

5. Selecting the appropriate license size
The licenses for the Editor and the Runtime are calculated by adding up the necessary TAGs or IOs.
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CALCULATION VIA TAGS
1 TAG equals 1 variable. For determining the license size, consider the total number of TAGs (=
variables) of the following drivers:


PLC drivers and bus drivers

Variables of the following drivers do not count:


internal driver



system driver



mathematics driver



simulation driver

You can license TAGs for the Editor and the Runtime in the following gradation:


64 TAGs



128 TAGs



256 TAGs



512 TAGs



1,024 TAGs



2,048 TAGs



4,096 TAGs



8,192 TAGs



16,384 TAGs



65536 TAGs



unlimited

A license upgrade to a higher number of TAGs is possible at any time.

CALCULATION VIA IOS
License can also be based on I/Os. For determining the license size, consider the total number of IOs of
the following drivers:
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PLC drivers and bus drivers

Variables of the following drivers do not count:


internal driver



system driver



mathematics driver



simulation driver

Data type

Valence

1 bit

1 I/Os

1 bytes

8 I/Os

1 WORD

16 I/Os

1 DWORD

16 I/Os

1 float

16 I/Os

1 string (max. 64 characters)

16 I/Os

If you cannot find the desired data type in the list, it is because of the selected driver. Some drivers have
a specific denotation of the data types. You will find more information in the driver documentation of
the driver you use. You will find this either in the online help in the Drivers section, as a PDF file on our
installation medium or on our website www.copadata.com (http://www.copadata.com) in the
download section.

Example
96 binary and 20 numerical values are to be visualized in zenon:
Multiply the 20 numeric values with 16 and you receive 320 I/Os. Add these to the 96
binary values. As a result you get 416 I/Os, which now are the basis for the license size.
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In the status line of the detail view of the variables the following information can be found:



How many I/Os are used currently.



How many I/Os are licensed.

An example:


3799/550/1: 3799 entries exist, 550 are listed because of a filter, one entry is selected.



For project 22730 an unlimited number of I/Os is licensed.

NOTE FOR CLIENT LICENSE
You can use client licenses if:


The start project is a standalone project or a client



The start project uses a maximum of 64 days when a license is required, if it is not a client



All subprojects are clients

6. Types of licensing
You can license zenon in different ways:


Soft licensing (on page 11): Requests a unique PC identification number when the editor or
Runtime is started.
Characteristics:
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The license cannot be stolen.



The license is computer specific.



Practical for notebooks.

Dongle licensing (on page 12): Looks for a hardware dongle at a parallel port or USB port when
the editor or Runtime is started.

Dongles are available as:


Workplace dongle:



Network dongle: A certain number of licenses are booked on a central dongle on the
network, which can be used at the same time as concurrent-use licenses.

Dongle characteristics:


Easy to use



A license can be taken from one PC to another by simply moving the dongle.



No problems due to hard disk failures

Information
If there is no license or all licenses are are assigned in the network, then the editor or
Runtime starts in demo mode (on page 6).

6.1

Soft licensing

The soft license assigns a computer with a unique identification. In doing so, certain components of the
computer are examined. This license always only works on a certain computer. If it is to be transferred
to another computer or too many components on the licensed computer are changed, it must be
reissued.
To obtain a software license:
1.

In the File menu, select: General configuration -> License product

2.

The licensing dialog (on page 4) opens

3.

enter the serial number:
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4.

Click on Request soft license

5.

The product licensing dialog opens
If this has not happened, enter the serial number

6.

Click on License request for soft licensing

7.

Enter your contact details

8.

click on Next.

9.

There are two possibilities for sending these:
a) automatic


Click on the Send to button



Select the desired COPA-DATA organization



When clicking on OK, the license request is sent by your email program



via button Print you can print your copy or send it to a connected fax machine

a) manually


Click on the Finish button



The license request is saved as a text file; an information window informs you of the
name and save location



the file is automatically opened in the Text Editor



send the email by email or fax to your sales partner

As soon as you have received your license data, reopen the licensing dialog and enter your activation
number.

6.2

Dongle licensing

With dongle licensing, a dongle is connected directly to the computer for an individual workspace
license or to a network computer for a network license. zenon uses two dongle systems:


Wibu key (on page 13)



CodeMeter (on page 16)

Both systems are automatically included in the installation of zenon. Users who already work with a
Wibu key will continue to receive licenses for their Wibu key dongles.
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In general, no further settings need to be made for dongles used locally. The use of network dongles
may mean that individual configuration is necessary. You can find these in the respective dongle
software. For details of this, see the chapters on the Wibu key (on page 13) and CodeMeter (on page
16).

6.2.1

Wibu key

A Wibu key can be used at a single workplace or in a network. The dongle must be active in a USB port
or parallel port on the local computer or as a server on a network computer.
To check the settings of the stick:
1.

Open system control

2.

Open Wibu key

3.

Select the stick to be tested on the local computer or on the network

To list server Wibu boxes in the network, click on the Read in button
4.

Check if the number in the last column of the second row is identical with the starting number of
the stick

You can read more about the operation of the stick in the network dongle (on page 14) chapter.
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Network dongle
To use a Wibu key in the network as a dongle, the server and client must be configured accordingly:


Server configuration (on page 14)



Client configuration (on page 15)

Attention
WibuyKey uses port 22347. This port is fixed and cannot be changed. Note:


If a firewall other than that integrated into the Windows operating system is
used, this port must be enabled if you wish to use the Wibu key as a network
dongle.

Configuring the server
The Wibu-Key server has to run on the dongle server. The Wibu-Key server can be configured either as
an application (e.g. started via Autostart) or as a service.
On installing the Wibu-Key software the options
32 Bit WkNet/WkLAN network server
Install as NT service with Autostart
have to be activated, so that the Wibu-Key server is installed as a service (recommended).
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In order to start the Wibu-Key server as an application, a link to the file WkSvW32.exe has to be
created in the Windows Autostart.
The file can be found in the folder C:\Programs\WIBU-KEY\Server\.

Configuring a client
Some network settings for the client have to be entered in the Control Panel. Under Wibu key
subsystems, you can select the type of network access you use. We use WkLan.
Under Server Name/IP address either the server name or its IP address or a mask for the IP address is
entered. With Browse the list is filled with all found dongle servers.

The entries are processed in the sequence of the list and also can be combined.
If the first entry is a certain server, it is checked, if the dongle server service runs on that PC and if a
dongle is plugged in (faster!). If no dongle is found here and the next entry is a filter mask, all PCs in the
network going with that filter mask are are tried out.
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On the Contents page, the server(s) where the dongles were found should then be listed:

6.2.2

CodeMeter

CodeMeter can be used at a single workplace or in a network. The CodeMeter USB stick must be active
in a USB port on the local computer or as a server on a network computer. The dongle firmware must be
at least version 1.16 or above.

Attention
If the dongle is removed during operation, the editor closes. The editor then opens in
demo mode until a valid license is recognized.

To configure, start the CodeMeter control center administration application via: Windows Desktop ->
Start -> All programs -> CodeMeter -> CodeMeter Control Center.
The CodeMeter control centre opens with 3 tabs:
Licensecontains information on the dongles found.
Events: Displays the number of sticks connected, the license entries, the

firm items found and all access
to the CodeMeter Runtime server. To log the entries on a permanent basis, activate the logging entry
in the file menu.
Allocation: Configures the allocation of licenses.
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LICENSE

TAG

Description

License

Lists all active CodeMeter sticks

Name

Individual name of the stick selected; can be assigned
with the button on the right.

Serial no._

Serial number of the stick selected.

Version

Firmware version of the selected stick.

Status

Status of the selected CodeMeter stick.

Deactivated

The stick connected is deactivated and cannot be used by
any application.

Activates when connected

The Stick is activated so long as it is connected; it is
automatically deactivated after it is removed from the PC.

Activated

The stick is fully activated and remains activated after it is
removed.
Recommended status: Ensures that unauthorized persons
do not have access to licenses and personal data (such as
CmPasswordManager) if the stick is lost.
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License updating

Starts the assistant to add, amend and delete licenses.

Eject

Allows the stick to be ejected.

Change password

Enables the password to be changed.

CodeMeter has been started/stopped

Information on whether the CodeMeter service is
running. Can be changed in the Action menu.

WebAdmin

Starts the web browser with the administration user
interface for network dongles Port 22350 must be open
for this, for details, see the chapter on network
administration (on page 19).

Update certified time
You can update the certified time saved in the dongle via the CodeMeter time server. To do this, you
need an active Internet connection.
To update the time:
1.

Start the CodeMeter WebAdmin

2.

Check your network settings (on page 26):
a) Are the proxy settings correct in CodeMeter Webadmin?
b) Is your access data up-to-date?

3.

Go to the Contents -> CmStick menu

4.

Click on the Update button.

5.

You are notified that all sticks have been updated with this.

6.

Click on OK.
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7.

You receive information on the update carried out. In the event of an error message (on page
34), you primarily check your access data.

Network administration
For network administration, start the WebAdmin user interface by clicking on the WebAdmin button in
the CodeMeter control center. Detailed information on the individual settings can be found in the
CodeMeter WebAdmin help pages. You get to this via the Help button in WebAdmin. The most
important options and instructions are also in this document:


CodeMeter stick administration (on page 20)



License administration (on page 21)



Saving license data (on page 21)



Network settings (on page 26)



Proxy settings (on page 26)

Attention
CodeMeter WebAdmin uses port 22350. Note:


If a firewall other than that integrated into the Windows operating system is
used, this port must be enabled.
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If the port is changed, the WebAdmin surface cannot be started, because the
port is part of the address, for example:
http://localhost:22350/Content.html?BoxSerial=2-1355435

In this case, use appropriate freeware tools or standard Windows tools to
determine which port is currently being used and enter this address into
the address line of the browsers instead of 22350. Then change the port
back to 22350 in WebAdmin.

CodeMeter sticks
WebAdmin starts in Contents/CmStick view.
Here, you select the desired dongle in a drop-down list and can see its data and status as configured in
the control center (on page 16).
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TAG

Description

CmStick

Drop-down list of recognized sticks.

Name

Shows the name given in the control center (on page 16).

Hardware

Hardware version of the stick.

First drive

Drive information for the stick, drive sizes are only given
for sticks with flash memory.

Status

Activation status as defined in the control center (on page
16).

Certified time (on page 18)

The certified time saved on the stick. is updated using the
update button.
to update using the CodeMeter Timeserver, you
require an active internet connection. Ensure that the
network settings (on page 26) are correct, in particular in
relation to current access data.

Box time

Internal time saved on the stick.

System time

Local time on the CodeMeter Runtime server.

Free memory

Free memory available on the stick. To defragment the
memory, click on the Defragment button.

Licenses
You administer your licenses in the Licenses tab in the Contents menu.


Select the desired dongle from the drop-down list.
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You can find information on the licenses of these dongles below the Ing. Punzenberger
COPA-DATA GmbH subheading.
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TAG

Description

Product Code

Numerical value for the product. Clicking on the number
leads to the details.

Name

Ing. Punzenberger COPA-DATA GmbH

Usage units

If applicable, display of usage units remaining.

Expiration date

If applicable, the expiration date is shown. zenon
switches to demo mode (on page 6) after this point in
time.

Activation date

If applicable, the activation date is shown. zenon switches
to demo mode (on page 6) after this point in time.

Number of licenses

Total number of licenses



Click on the number in the Product Code column for details.
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TAG

Description

Dongle number

Must correspond with the number of the active dongle.

TIME LIMITS
A dongle can also have a time limit:


Expiration date



Time period for use

The dongle is equipped with an expiration date.
In the Licenses tab in the Contents menu, the expiration date is given in the expiration date column
with the date and time in UTC format.

The dongle is equipped with a specified usage period. This starts from the first time that zenon Editor or
Runtime is used. To check the time limit:


Navigate to the Licenses tab in the Contents menu
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Click in the entry under Ing. Punzenberger COPA-DATA GmbH on the digit in the Product Code
column



The Product Item Details window opens



You can see the licensed period and the start date in UTC format in the Usage period line.
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Network and Proxy
For faultless communication with a Network dongle and the start of WebAdmin, correct network
settings are a requirement.
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TAG

Description

Network address

Select an IP address to which the CodeMeter Runtime
server should connect.

Standard: All.
The connection is made to the first CodeMeter Runtime
server found.
The choice of a defined address is primarily necessary if
the computer is functioning as a network license server
and has several
network cards.
Network port

Port for CodeMeter communication in the network.

Standard: 22350
The value can be adjusted individually. In this case, it
must be ensured that all CodeMeter Runtime servers use
the same port.
do not change port.
UDP response time

Maximum response time within which a UDP request
must be answered.

Standard: 1000 milliseconds.
Start as server

Active: The computer becomes a CodeMeter network
server and makes all its licenses available in the network.

Server search list

Here, specific CodeMeter network servers can be defined
by entering computer names or IP addresses. Then only
the servers defined in the list are searched for. This way,
requests from clients are directed to a defined
CodeMeter Network server.

If a CodeMeter Server is in a different
subnetwork, use the IP address for the search list.
This search list should only be used if the CM stick
cannot be found in the network.

PROXY SETTINGS
For access to CodeMeter services in the internet, such as time server, enter the applicable access data
for your company here.
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Attention
CodeMeter notes this access data. If you regularly change your access password, you
must also change this in the CodeMeter WebAdmin proxy settings!
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requesting a license
To request or update licenses for CodeMeter, select the the Update license button in the Licenses tab
in the CodeMeter control center (on page 16). The license update assistant starts:

Decide if you are:


requesting a license



entering a license update



wish to create a receipt for COPA-DATA

LICENSE REQUEST
With license requests, you can:
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extend an existing COPA-DATA license



create a new COPA-DATA license



To add another COPA-DATA license:




To create a new COPA-DATA license:




Select Ing. Punzenberger COPA-DATA GmbH

enter the CodeMeter FirmCode that you received from COPA-DATA.

Select a save location for your license request.

Adapt license
You can adapt the scope of your license concerning extent and runtime at any time. To do this:
1.

order the desired change at COPA-DATA

2.

You will receive a *. WibuCmRaU file for your dongle.

3.

install it:
a) either via double click on the file
b) or by dragging the file ion the CodeMeter control center

4.

You will receive a message about successfully updating your license.
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If you receive error message (on page 34) 229, the license on the dongle is already up to
date
If it is necessary for your license request to create a .WibuCmRaC file or to install the .WibuCmRaC
file with the update manually, follow the instructions in chapter Update license manually (on page 31).

Request or update license
To update your license manually:
1.

create a .WibuCmRaC file

2.

send the file to COPA-DATA

3.

you will get an updated .WibuCmRaU file

4.

copy this to the dongle

CREATE WIBUCMRAC FILE
1.

Make sure that the CodeMeter dongle is connected to your PC.

2.

open the CodeMeter control center, e.g. via Start -> Programs -> CodeMeter ->
CodeMeter Control Center

3.

on tab License click button Update License

4.

The license update assistant starts
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5.

click on Next.

6.

select Create license and click Next.

7.

select Enhance existing license
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8.

click on Next

9.

in the following dialog click Next again

10. select the desired location for the appropriated .WibuCmRaC file
11. click on Apply
12. the .WibuCmRaC file is created
13. send the file to sales@copadata.com

INSTALL WIBUCMRAU FILE
You will receive an updated *.WibuCmRaU file from COPA-DATA.
Install the file via double click on the file on the dongle.
Alternatively:
1.

open the CodeMeter control center

2.

select install license update

3.

follow the instructions of the installation wizard
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Troubleshooting
Errors

Solution

zenon only runs in demo mode.

Check
 your licenses
 The connection to the network dongle
 if the license information (SERIAL7= and ACTIVATIONKEY7=) was
correctly entered in zenon6.ini. Take care for possible blanks behind
the serial number (SERIAL7=) or the activation key
(ACTIVATIONKEY7=).
Pfad for zenon6.ini:
Vista/7/8: C:\ProgramData\COPA-DATA\System

Dongle is not found.

 Check the network settings (on page 26).
 If the stick is in another domain, add it to the server list (on page
26).

 Increase the UDP response time (on page 26).
 If it is a virtual machine, then configure the stick as removable
media (on page 35).
Configuration as removable media can - depending on
the computer configuration - also lead to a computer no longer
booting.

 Configure the stick as HID (on page 38).
Certified time cannot be updated.

Check:
 Proxy settings (on page 26), especially access data and Password
 List of time server under Settings -> time server
for example: cmtime.codemeter.com, cmtime.codemeter.de,
cmtime.codemeter.fr, cmtime.codemeter.us

Error message at updating the license:
Error at updating the CmSticks
x-xxxxxxx:
This update can no longer be read in.
The content of the CmStick has a
newer version, error229.

Windows operating system shows the
message:

The update for this license has already been written to the
dongle. The dongle is up-to-date.

The dongle is identified as local memory. In some cases, this can
lead to the operating system giving the message "Insufficient
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Low Memory

memory".
This message can be ignored.
Alternatively, the dongle can also be configured as removable
media. For details about configuration see the Configure
dongle as removable storage device (on page 35) chapter.
Configuration as removable media can - depending
on the computer configuration - also lead to a computer no
longer booting.

Windows operating system no longer shows
symbol for the Recycle Bin.

This may happen if the dongle is identified as a fixed local
network.
Alternatively, the dongle can also be configured as removable
media. For details about configuration see the Configure
dongle as removable storage device (on page 35) chapter.
Configuration as removable media can - depending
on the computer configuration - also lead to a computer no
longer booting.

Configuring the dongle as removable media
The dongle is integrated into the system as a local data medium as standard.
lead to


the operating system reporting too little memory for the dongle



the icon for the Windows Recycle Bin no longer being displayed



the dongle not being found in virtual machines

In some cases, this could

This behavior of the Microsoft operating system has no effect on the functioning of Windows or zenon.
If the behavior needs to be changed, the dongle can also be configured as removable media. This change
is not recommended, because it can also lead to the computer no longer booting.
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Attention
With configuration as removable media:
 The booting of the computer can be prevented for with computers that can boot from a USB drive
 The dongle appears as a drive in the task bar and can be removed (ejected) at any time

CONFIGURING THE CODEMETER DONGLE AS REMOVABLE MEDIA
There are two methods available to you to reconfigure the CodeMeter dongle from a local drive to
removable media:


Using the CodeMeter command prompt



With the CodeMeter disk configuration tool

1.

Open a CodeMeter prompt:
Start -> All Programs-> CodeMeter-> Tools-> CodeMeter Command Prompt

2.

Read off the current configuration:
cmu32 -s <serial> --show-config-disk

Note: <serial> must be replaced by the serial number of your CmStick, for example 1-123456
3.

Configure the CmStick as removable media.
cmu32 -s <serial> --set-config-disk RemovableDisk

4.

Remove the dongle and connect it to the computer again

To configure the dongle as a local drive again, use the following command:
cmu32 -s <serial> --set-config-disk LocalDisk

In current versions of CodeMeter from 4.50, the CodeMeter Disk Configuration tool is not supplied.
The tool provided with earlier versions can be used however. If you are no longer able to obtain the tool
from CodeMeter as a download, you can also contact support@copadata.com.
Configuration with CodeMeter Disk Configuration:
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1.

Open CodeMeter Disk Configuration

2.

Select the desired dongle
(the program only shows locally-installed dongles)

3.

open tab Options

4.

In the Disk Type property, double click on the Local Disk entry
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5.

a drop-down list is displayed

6.

select the entry Removable Disk

7.

Click on the Apply Changes button

8.

Remove the dongle and connect it to the computer again

Codemeter HID support
Codemeter supports, from version 5.0, the Human Interface Device (HID) class of the USB standards.
Codemeter dongles can therefore log onto the system as a human interface device instead of a mass
storage device. Special USB host drivers do not need to be installed for configuration, because the
functionality is provided by the operating system. HID support is available for all Codemeter dongles
without memory.
Requirements:


Codemeter container with the identification "2-xxxxxxx" (Samsung chips)



CodeMeter firmware 2.02 or higher

MASS STORAGE DEVICE TO HID
To switch USB communication from mass storage device to human interface device:
1.

Check, in CodeMeter WebAdmin, the status in the Content (CmContainer) tab.
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2.

A drive is assigned but there is no flash memory.

3.

Call up the Codemeter command line interface cmu: Start -> Program Files -> CodeMeter -> Tools ->
CodeMeter Command Prompt.

4.

Enter the following commands in the command line interface that has been called up:

cmu32 /s [Boxenmaske-Seriennummer] --set-config-disk HidCommunication

5.

The current status is displayed in the following output from the command line interface:

cmu32 - CodeMeter Universal Support Tool.
Version 5.00 of 2013-Jan-30 (Build 1039) for Win32
Copyright (C) 2007-2013 by WIBU-SYSTEMS AG. All rights reserved.
- CmStick/C with Serial Number 2-2251132 and version 2.01
Version: 2:01 AM
Flash Size: no real flash available
Virtual Drive: E:
Configuration: LocalDisk with ActivePartition
File System: FAT32
Communication: Mass Storage Device
Boot-Code: Int18 Boot Code
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Mdfa: 0x539

6.

Remove the dongle from the computer.

7.

Reconnect the dongle to the computer.

8.

In the CodeMeter Control Center, the switch to HID is shown in the Events tab.
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9.

Check the drive in CodeMeter WebAdmin, in the Content/CmContainer tab. Nothing should be
entered.

HID TO MASS STORAGE DEVICE
To switch the USB communication from human interface device (HID) to mass storage device:
1.

Check, in CodeMeter WebAdmin, the status in the Content (CmContainer) tab.
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2.

No drive is assigned.

3.

Call up the Codemeter command line interface cmu: Start -> Program Files -> CodeMeter -> Tools ->
CodeMeter Command Prompt.

4.

Enter the following commands in the command line interface that has been called up:

C:\Users\fs>cmu32 /s [box mask-serial number] --set-config-disk MsdCommunication

5.

The current status is displayed in the following output from the command line interface:

cmu32 - CodeMeter Universal Support Tool.
Version 5.00 of 2013-Jan-30 (Build 1039) for Win32
Copyright (C) 2007-2013 by WIBU-SYSTEMS AG. All rights reserved.
- CmStick/C with Serial Number 2-2251132 and version 2.01
Version: 2:01 AM
Flash Size: no real flash available
Virtual Drive: No drive assigned (HID)
Communication: Human Interface Device (HID)
Please replug your CmDongle to apply the changes.

6.

Remove the dongle from the computer.

7.

Reconnect the dongle to the computer.
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8.

In the CodeMeter Control Center, the switch to MSD is shown in the Events tab.

9.

Check the drive in CodeMeter WebAdmin, in the Content/CmContainer tab. A drive is entered but
there is no flash memory.
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7. Command line parameter for licensing tool
The licensing tool can be controlled with the following flags as parameters:
Passing over a parameter is done by putting a `/` or a `-` before the parameter:
for example: /silent or -silent
TAG

Description

request

forces the program to omit the first dialog and go straight to the dialog for
requesting the activation key
(it does not matter if the flag /silent or -silent is also used)

sernum:<num>

forces the program to use the serial number which is passed with <num>
for licensing instead of reading the number from the zenon6.ini file.

actkey:<key>

forces the program to use the activation key which is passed with <key>
for licensing instead of reading the key from the zenOn6.ini file.

silent

forces the program to not show a dialog. The file License.txt is still created.

mailto:<addr>

works only in connection with the flag silent and forces the program to send
the license request to the specified address <addr> via e-mail.

8. Remote licensing
To allocate a license to a computer via remote connection:
1.

in the context menu of the project select Remote Transport -> Change password and display licensing

2.

start the Remote Transport
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3.

as soon as the connection is established, the licensing of the remote computer is displayed

4.

enter the serial number and the activation number of your license form

5.

confirm the input by clicking OK

9. Characteristics of the Server Client operation
Licensing of modules in the server client operation has the following characteristics:

HISTORIAN
The following cases are distinguished:


Server and client licensed: Archives can be opened and edited at the client



Server licensed and client not licensed: Archives can be opened but not edited at the client



Client not licensed and started as standalone: Archive window can be opened; the individual
archives cannot be opened

AUTOMATIC LINE COLORING (ALC)
The following cases are distinguished:


Server licensed and client not licensed: ALC functionality is available unrestrictedly



Client not licensed and started as standalone: ALC functionality is not available
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Information
If the Server is licensed for the Energy Edition, ALC is also licensed.

BATCH CONTROL
The client gets the license from the server and does not need its own license. If the server does not have
a license of its own, the client cannot use the module.

ENERGY MANAGEMENT SY STEM
The following cases are distinguished:


Server licensed and client not licensed: EMS functionality is available unrestrictedly



Client not licensed and started as standalone: EMS functionality is not available

MESSAGE CONTROL
The client gets the license from the server and does not need its own license. If the server does not have
a license of its own, the client cannot use the module.

The everywhere Server gets the license from the Runtime license and does not need its own license.
The Everywhere Server can not be used, If the Runtime does not have a corresponding license.
For this reason, it may happen that the Runtime is running, but the Everywhere Server can not be
started because of missing license rights. Please use in this case the license tool (on page 4) in order to
receive a corresponding license.
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